KDE3

跳转至: 导航, 搜索

从 openSUSE 11.2 开始,KDE3 桌面环境就不再是发行版正式支持的一部分了,但是还可以从不受正式支持的 KDE:KDE3 供应源来安装 KDE3。

KDE3 的状况

openSUSE 11.1 允许安装(或同时安装)KDE3 或 KDE4,以缓解对过渡到 KDE4 的不适。但从 openSUSE 11.2 所携带的 KDE 4.3.1 开始,KDE4 就被认为能够替代 KDE3 了,而且由于精力方面的原因,KDE3 就不再提供支持了。

openSUSE KDE 团队一直忙于整合和支持 KDE4,没有多余的精力放在 KDE3 上。尽管 KDE3 实际上已不再受上游 KDE 项目所开发和支持,不再有什么变化,但是(若要在新版的系统上使用)仍要花大量的精力来调适她与其他软件之间的磨合。所以 openSUSE KDE 团队决定,与其将精力花在过气的 KDE3 上,不如认真维护好 KDE4。

如果您有兴趣(帮助)维护 openSUSE 的 KDE3 供应源,欢迎您来维护。您可以通过 #opensuse-kde 频道或 opensuse-kde@opensuse.org 邮件列表联系 KDE 团队。

KDE:KDE3 供应源

注意 KDE:KDE3 供应源不再受正式支持,而且也不再接受 Bug 提交。

想要在新的 openSUSE 系统上安装 KDE3,首先您得先添加供应源。然后您还需要安装 kdebase3-session 软件包,再加上其他如 kdegames、kdegraphics 等的一整组的软件包。这里顺便一提的是,KDE3 的软件包可以运行于 KDE4 之上,而 KDE4 的软件包也可以运行于 KDE3 之上;例如可以在 KDE4 里运行 1.4 版的 Amarok(KDE3 里的软件),也可以在 KDE3 里运行 2.1 版的 Amarok(KDE4 里的软件)。

如果想以 kdm3 为默认的会话管理器,您需要设置 /etc/sysconfig/displaymanagerDISPLAYMANAGER="kdm3"(也可以通过 YaST 里的 etc/sysconfig Editor 模块来设置)。

邮件列表

以下是 openSUSE 上 KDE3 专用的邮件列表。

  • opensuse-kde3@opensuse.org - openSUSE KDE3 邮件列表
订阅 | 退订 | 了解 | 存档列表